Sign in

Gitlab Pages glitch: A file with this name already exists

#2095
j2l2

I don’t see “Tools -> Log viewer”

Operations > Logs is empty

In CI/CD jobs`, all jobs are passed`

No issues

Last task is:

Merge branch ‘publii-deploy-1584327528716’ into ‘master’

it claims pipeline passed, deployed (and request pages states it was merged)

but there are lots of active branches beside master. Especially the last commit is still an active branch.

I tried to delete all merged branches, including the successful one of yesterday. All branches but master are gone.

 

 

I made a tiny change and tried again to sync from Publii. It failed again.

It REOPENS the last branch merge operation from 22h ago!

I confirm it was deleted and the merge request reappeared again.

Like if Publii was pushing again the same commit.

 

Since I don’t really care to delete gitlab content anymore, I tried deleting publii-files.json only. It didn’t help.

I deleted /media and synced again. It didn’t help.

I deleted each folder and files and synced again. It didn’t help.

Until I deleted /public

So, even one file in /public is enough to break Publii sync.

 

 

Can you test on your side, please?