Sign in

An error occured during connecting to the server. Please check your server sett

  • This topic has 1 reply, 2 voices, and was last updated 1 year ago by .
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2854
    iaro

    I use Publii Version 0.3.6.0 (13213)

    When i want to sync the website via sftp i got the following error:

    “An error occured during connecting to the server. Please check your server settings or try again.”

    Several times before it worked smoothly with no problems.

    This is what i tried to find the error:

    • I doublechecked the user and password, they are ok.
    • I tried to open an sftp-connection via FileZilla with the same user and password, it worked smoothly.
    • Checking the errorlogs -> no hint to that error
    • Trying to get a connection via Publii with ftp -> same error.

    I look at documents/Publii/sites/mysitename/input/config/site.config.json:

    “deployment”: {
    “protocol”: “sftp”,
    “relativeUrls”: false,

    “password”: “publii and-here-is-the-sitename”,
    “askforpassword”: false,

    The password ‘publii andmysitename’ isnt my password! It seemed that publii stored a wrong value into this.
    When i overwrite it in the Publii-GUI it was not stored in the site.config.json file.

    There stands always ‘publii ‘ and my sitename.

    Any ideas?

     

     

     

    #3015
    Tomasz Dziuda

    Hi,

    Publii does not store password as a plain text in the site settings. It is due security reasons. The value in the password field is used to restore password from the OS built-in password manager.

    Please check server settings and check if password in the settings is ok (you can show password in the Publii UI). If you will get the same value as in the site settings file – then it must be a bug (in some Publii prerelease version we had a problem with password overrides). Then please put your correct password and save server settings again.

    The same problem can occur if you have migrated website files from other computer – you have to set a password again.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.