Sign in

Bug: On older Pages all the options in “Paragraph” can not be applied.

  • This topic has 1 reply, 2 voices, and was last updated 3 months, 3 weeks ago by .
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7357
    Harald Krause

    All the options on the “Paragraph” Combo box are disabled when you for example want to highlight something, Those Pages were created in an older Version of Publii.

    The paragraphs are originally “div” blocks.

    There is a Workaround by directly edit <p class=”msg msg–highlight “> in the HTML Editor, but this is annoying…

    #7368
    Bob

    Look into a config.json file ‎⁨(Documents ▸ ⁨Publii⁩ ▸ ⁨sites⁩ ▸ ⁨YOUR_SITE ▸ ⁨input⁩ ▸ ⁨themes⁩ ▸ ⁨YOUR_THEME) and edit the custom elements by adding an additional selector e.g. div. This way, the paragraph options will also affect DIV elements in the post body.

    {
        "label": "Info",
        "cssClasses": "msg msg--info",
        "selector": "p,div"
    },
    {
        "label": "Highlight",
        "cssClasses": "msg msg--highlight ",
        "selector": "p,div"
    },

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.