Sign in

[Bug] Unable to store files

  • This topic has 4 replies, 2 voices, and was last updated 3 weeks, 6 days ago by .
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7769
    wefer

    Today I upgraded Publii to 0.40.1 (Windows).

    Now, when I try to sync my website I receive this message:

    Error! Application was able to connect with your server but was unable to store files. Please check file permissions on your server.

    I changed nothing in my server and I can connect without problems by FTP. Obviously is something related with the new version.

    Even more confusing, I’ve several websites in the same server, using exactly the same configuration in Publii, and all are syncing fine except this one!

    Some data about configuration:

    • SFTP
    • Use relative URLs (I changed this setting without any result)
    • Port 22
    #7770
    Tomasz Dziuda

    Hi,

    First of all – please check if the path provided under server settings is ok – this message means that Publii is able to connect with your server using provided credentials, but location where it tries to save files is unavailable for Publii to write.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7772
    wefer

    Yes, absolutely, the path is ok.

    Moreover, I haven’t modified the path and it was working fine before the update. Even I tried to copy/paste the path in FileZilla and all is working ok with this software. The path is:

    /var/www/vhosts/[website name]/httpdocs

    I tried adding a final slash, too.

    I’m stuck with this problem that makes me impossible to update my website.

    I’m not sure if could be related, but first time after upgrade, when I try to preview my website I received an error (sorry, I don’t remind the text). I rebooted Publii and then preview was working fine. Other of my websites give me an error (could be the same) when I try to sync first time: “Cannot read properties of undefined (reading ‘trim’)“. But after rebooting Publii that websites works fine, even the sync.

    Seems like there are some broken things with this upgrade, at least in my case. It’s possible to roll back installing previous version or is a bad idea?

    Thanks.

    #7774
    wefer

    Solved!

    Seems like the upgrade it had changed the password! The correct password was changed with this words: “publii [name of website]“. I didn’t notice it until I show the password.

    It’s nearly impossible that I changed it accidentally. Moreover, first attempt putting correct password failed, too. I need to save settings, close Publii and reopen it again in order to work fine.

    It’s certainly strange.

    Thanks for your nice work!

    #7797
    Tomasz Dziuda

    If you get such words instead of password it means that some error occurred during retrieving password from keychain/safe password storage. Anyway – good to know that now all is ok 🙂

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.