Sign in

Button text is blank until mouseover

  • This topic has 5 replies, 3 voices, and was last updated 5 months, 3 weeks ago by .
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5935
    wesley

    We’re using a modified version of the Simple v2.0.4.0 theme for this website:

    https://www.riverwaveneytrust.org/

    For some reason, the buttons all show blank text until you mouseover – see the newsletter signup towards bottom of homepage.

    Any idea why this is happening?

    #5937
    itips3727

    The code for your Subscribe button is currently:

    .btn, [type=button], [type=submit], button {
    background: #ff8c00;
    border-color: #ff8c00;
    color:#ff8c00
    }

    If you’ve done this in your Tools > Custom CSS tool, try changing to:

    .btn, [type=button], [type=submit], button {
    background: #ff8c00;
    border-color: #ff8c00;
    color: #fff
    }
    

    or:

    .btn, [type=button], [type=submit], button {
    background: #ff8c00;
    border-color: #ff8c00;
    /* color:#ff8c00 */
    }
    

    To make your Subscribe button stand out better, try:

    .btn, [type=button], [type=submit], button {
    background: #ff8c00;
    border-color: #ff8c00;
    color:#000
    }
    

     

     

     

     

    #5938
    wesley

    I see that now, thank you!

    I tried to add your second code suggestion to the custom CSS section but it doesn’t seem to do anything when I preview. Should I use the theme override in the input folder instead? There is currently a file called main.css in there but it doesn’t have the same code as the style.css file. Should I create a new file called style.css in the override folder and add your code?

    #5939
    itips3727

    I suppose much depends on how you set up your ‘modified’ theme. If you were just making changes to the ‘Simple’ theme, the above options should work in Tools > Custom CSS.

    If you created an entirely new theme based on the ‘Simple’ theme, and gave your new theme its own name, support files, etc., the Tools > Custom CSS should still work, so long as you choose your new theme name in the Publii Site settings.

    But it sounds like you’ve taken a different approach. Normally, you wouldn’t want to disturb main.css, just use Tools > Custom CSS to override the text colour for your Subscribe button. So I’m not quite sure what to suggest. Maybe @Bob can help.

     

    #5940
    Bob

    @itips3727 described the best way.

    The style.css file is the final file, a sum of :
    `theme-variables.js output + main.css + GDPR popup CSS + visual-overrides.js output + custom CSS`
    So never overwrite it, as it will be overwritten every time the page is rendered.

    More details: https://getpublii.com/dev/how-the-theme-is-rendered/

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #5941
    wesley

    Cool, thanks for your help. I tried the custom CSS again and it does work but only with your option 1 or 3 (so actually declaring the text colour rather than commenting it out).

    And thanks for the clarification Bob.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.