Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Configure Server for local development

  • This topic has 4 replies, 2 voices, and was last updated 1 year ago by .
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #9132
    Avatar photoSergio

    Hi all!

    I used Laragon (laragon.org) for web development, ; I configure the server on “Zip”:

    • Website url: (http or https is equals) sitename.test (.test is a local tld)
    • Output type: Non-compressed catalog
    • Output directory: c:\laragon\www\sitename

    but the button “Save Settings” not work; the buttone “Visit website” is disable and I see “Configure Server”…

    The virtual host for the site is create and respond at https://sitename.test.

    Any suggestion?

    Thanks!!

    #9168
    Avatar photoTomasz Dziuda

    Hi,

    The “Visit website” button is not working for the manual deployment method.

    Unfortunately I cannot reproduce the issue with saving settings for such configuration – can you provide some more details?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9206
    Avatar photoSergio

    Hi,

    I didn’t understand the “use relative urls” option. I disabled it and in “website URL” I insert the local url…

    But another question: why Publii add “-files” to the name of folder in “output directory”? Is it possible to avoid this? Because my folder local website is “\mysite” and Publii make in this folder “\mysite\mysite-files” and when I visit the local url the site not working.

    Thanks!

     

    #9231
    Avatar photoTomasz Dziuda

    But another question: why Publii add “-files” to the name of folder in “output directory”? Is it possible to avoid this? Because my folder local website is “\mysite” and Publii make in this folder “\mysite\mysite-files” and when I visit the local url the site not working.

    It is a mechanism to protect files in the destination directory. Without it sometimes people reported that they have lost their files in the destination directory (it is emptied before deployment). At this moment there is no option to disable it, but I suppose that it is not a problem to navigate local domain to different path.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9253
    Avatar photoSergio
    Tomasz Dziuda wrote:

    It is a mechanism to protect files in the destination directory. Without it sometimes people reported that they have lost their files in the destination directory (it is emptied before deployment). At this moment there is no option to disable it, …

    Ok, consider an option that avoids adding the “-files”.

    .. but I suppose that it is not a problem to navigate local domain to different path.

    Not exactly…
    The local folder “\mysite” is the root of the site and the url “mysite.test”; the “mysite-files” subfolder is not considered by the web server.
    I have to delete the content and copy it to the mysite directory to see the result…
    Thanks anyway.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.