Sign in

Duplicate index post in /page/2 Editoral2 Theme

  • This topic has 13 replies, 2 voices, and was last updated 4 days, 8 hours ago by .
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #7956
    seb_oi

    I have my main index duplicated in /page/2
    The funny thing is that I don’t even have a post with id 2 (I deleted it some time ago). It generates a post identical to the main index. I have activated the option of concrete post in Front page and I can see how that same post is created with another slug and no idex. The totally detrimental thing is that this page/2 is with Index and follow in the robot tags. If I modify the pagination phrase it changes the path where this file is created, in site settings/url.
    my main index is duplicated

    How can I solve this?

     

    #7957
    Bob

    I’m not sure if I understand well, but if you set the post to display on the front page you should mark it as hidden and also noindex.

    screenshot-2022-08-03-at-18.40.00

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7968
    seb_oi

    I’m not sure if I understand well, but if you set the post to display on the front page you should mark it as hidden and also noindex.

    screenshot-2022-08-03-at-18.40.00

     

    Thanks for the answer, I have created several pages and I have never had this problem.

    I have the configuration as you show in the image.
    I have my main page indexed: https://gfrprebartechnology.com/

    The “source” page which is not indexed and hidden.
    https://gfrprebartechnology.com/gfrp-rebar-technology/

    And this other page that is generated by itself and is a clone of the first one. https://gfrprebartechnology.com/pagina/2

    “pagina” is the pagination phrase that I have chosen (it is the only page that appears in that folder, I do not understand very well where it is generated).

    #7969
    Bob

    I don’t understand how it works:

    This is a default main page : https://gfrprebartechnology.com/

    but what is this page: https://gfrprebartechnology.com/gfrp-rebar-technology/

    Both display the same content, which is impossible when you set the selected post to display on the frontpage; the fronpage should display only post content, not the posts listing.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7970
    seb_oi

    gfrp-rebar-technology/

    I have configured the post as “hidden” and with the following slug: gfrp-rebar-technology/
    As I show in the image

     

     

    #7975
    Bob

    So why the frontpage displays the post listing?

    screenshot-2022-08-03-at-19.27.05

     

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7980
    seb_oi

    <span style=”vertical-align: inherit;”><span style=”vertical-align: inherit;”>Entonces, ¿por qué la página principal muestra la lista de publicaciones?</span></span>

    captura de pantalla-2022-08-03-a-19.27.05

    It doesn’t really show the posts as such, I have used the style as if it did, they are links to the posts but it is not generating them automatically as you can see in the code.

    #7982
    Bob

    I don’t think I can help you, because I don’t really understand what’s going on here.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7984
    seb_oi

    I don’t think I can help you, because I don’t really understand what’s going on here.

     

    I understand it, it’s really weird. The best option I can think of is to create a new “site” in publii and copy page by page.

    Do you think I can have a problem creating a new site and uploading it to netlify with the tokens and id I have for my site?

    Will there be any “trash” files left because I uploaded it from the first site?

    Thank you very much for your answer. I really appreciate the project and support it. It is awesome

    #7985
    Bob

    Send me (in the private reply mode) the site backup or “input” folder, I will look at it tomorrow.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7986
    seb_oi

    Send me (PM) the site backup or “input” folder, I will look at this tomorrow.

    Thank you very much. I’m sending it right now. I updated publii a week ago, I don’t know if it could have anything to do with it.

    #7987
    seb_oi
    This reply has been marked as private.
    #7988
    Bob

    Change the value of the “Post per page” option (Theme Settings – Basic Settings) ) to more than the total number of posts, then pagination will not be created.
    Also, keep the “Disable homepage pagination indexing” option enabled.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7989
    seb_oi

    Change the value of the “Post per page” option (Theme Settings – Basic Settings) ) to more than the total number of posts, then pagination will not be created.

    Also, keep the “Disable homepage pagination indexing” option enabled.

    Solved! Thanks for your support

Viewing 14 posts - 1 through 14 (of 14 total)
  • The topic ‘Duplicate index post in /page/2 Editoral2 Theme’ is closed to new replies.