Sign in

Eliminate render-blocking resources in Pagespeed Tests

  • This topic has 7 replies, 4 voices, and was last updated 5 months ago by .
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5196
    Adwoox

    When I test my website, I see the error in the link : https://hizliresim.com/XjOV5Q

    What should I do to fix this problem?

    #5197
    Adwoox

    I’m using technews theme btw.

    Attachments:
    #5199
    Bob

    I suggest you dig into Google search.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #5201
    Adwoox

    Yeah Bob, i know how to search on google. 80% of articles are for wordpress not for Publii. Amazing answer by the way, you made my day.

    #5202
    Bob

    You’re welcome 🙂

    It doesn’t matter what CMS do you use.
    I can help you implement your changes to the Publii theme, indicate where to make them, but optimize an already highly optimized page, I’m afraid that due to the lack of time not anymore.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #5267
    Mick
    @ Adwoox While i don’t know of an easy way to fix this you can aleviate the problem by publishing through cloudflare and enable caching. Your external css files will then (eventualy) be served from an /assets/css/ frolder. And while your at it enable brotli compression and other optimizations on the speed tab.
    This will load your site over a HTTP/2 (or 3 with QUIC if you enable it) with server side push of the resources. This mitigates the problem.
    See this in action on https://woordenliefde.nl/.
    I know it’s not a real fix, but it may be a good work-around and as a bonus you get reasonably fast delivery from a local internet exchange.
    Cloudflare-Caching

    #5271
    Adwoox
    @ Adwoox While i don’t know of an easy way to fix this you can aleviate the problem by publishing through cloudflare and enable caching. Your external css files will then (eventualy) be served from an /assets/css/ frolder. And while your at it enable brotli compression and other optimizations on the speed tab.
    This will load your site over a HTTP/2 (or 3 with QUIC if you enable it) with server side push of the resources. This mitigates the problem.
    See this in action on https://woordenliefde.nl/.
    I know it’s not a real fix, but it may be a good work-around and as a bonus you get reasonably fast delivery from a local internet exchange.
    Cloudflare-Caching

    Thanks Mick, for a new website cloudflare is good option as you say. However, when the traffic increases, both the cost and the management can be a bit difficult at the cloudflare side. But i will try this as a temporary solution. Thank you again.

    #5277
    scotdill

    The issue is your fonts.

    To use the browser default fonts and remove the error your having ( will change the look of your site )

    Go to Theme—–>Fonts—-> then under Font Family Select OS Default Font + OS Default Font.

    Problem solved.

     

    If you do not like how your site looks with basic fonts, then you will have to endure the render blocking result as Publii currently doesn’t support self hosted fonts.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.