Sign in

Embedded video problem

  • This topic has 4 replies, 3 voices, and was last updated 2 weeks, 2 days ago by .
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6231
    masonbee

    OS: Kubuntu 20.04

    Publii version: v.0.38.3 (build 14238)

    Theme: Technews 2.3.0.0

    I seem to have a problem embedding videos. If I do a local preview they are fine but when the site is uploaded there is a blank box with “No video with supported format and MIME type found”.

    I have tried different browsers and operating systems, mpv instead of webm, making the file sizes smaller, wrapping the video tags in <figure class=”post__video”> and probably quite a few other things I can’t remember 🙂 For some reason I am stymied.

    For example on this page the first video is touristtrap.webm which is there if I put in the full URL but on the page it doesn’t show.

    The code in HTML view is,

    <video width="100%" height="auto" controls="controls"><source src="media/files/touristtrap.webm" type="video/webm" /></video>

    Any ideas on what I am doing wrong?

    #6234
    NitaaiKumar

    Maybe your remote server does not have the mime types set for webm or mkv? Try with mp4 and see too.

    #6243
    masonbee

    Maybe your remote server does not have the mime types set for webm or mkv? Try with mp4 and see too.

    Nope, no luck there but it’s a good thought as it is on lightspeed. I’ll put it on a clean Apache server and see what happens there.

    #6245
    kensquires

    @masonbee – It’s not your host.. after reading your post I thought I would try it on mine with a rather small mp4 file. It didn’t work, I then thought I got to be doing something wrong, so I took to option 2 and I opened up a blank html page in a different program and coded to view a html5 player myself and if I do it myself I can get it to run on my current web host but through publii for some reason it doesn’t work

    However I thought I would dig deeper and because of having super slow internet I thought I would use your video (hope you don’t mind) since it was already on a server and I found your solution…

    Right now you have it coded with the source for this: media/files/touristtrap.webm
    What I’ve learned about Publii is it requires a full URL so go back into publii where you have your video and change your source to this: https://masonbee.nz/media/files/touristtrap.webm

    I just tested it on my publii and I had your video play for me, like I said I felt the need to use yours cause my internet is slow but it was just merely for testing purposes.

    #6246
    masonbee

    Awww, it’s perfect. Such a simple solution 🙂 Thank you to you both. I will set this as closed.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The topic ‘Embedded video problem’ is closed to new replies.