Sign in

Error occurred during connecting to github

  • This topic has 3 replies, 1 voice, and was last updated 3 months, 3 weeks ago by .
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6817
    taddmencer

    I’m trying to upload my site to a Github repository.

    However, every time I hit sync, I get the following error:

    An error occurred during connecting to the server: E1

    {“code”:403,”status”:”Forbidden”,”message”:””}

    I’m not sure what I’m doing wrong here. I set everything up, successfully tested the connection. But I get hit with this error every time.

    I have my Parallel uploads set to ‘1’ to keep from getting nerfed.

    My branch is set to master, which is the only branch in my repository.

    I’m really confused what’s the deal.

     

    #6822
    taddmencer

    I will note this repository DOES already exist with a pre-existing Jekyll instance. Should I only use a fresh repository? Or, should I clear everything out of that repository first?

    #6828
    taddmencer

    I ended up working with this the most inefficient way possible.

    I finish whatever I’m doing in Publii.

    Try and sync to the website, which builds the page.

    Errors out. I mutter a few colorful frustrations under my breath.

    I go to the /Output/ folder. I copy everything in that folder.

    I go to my Github folder that holds my repository and paste all the contents in there.

    I open my Git client (I use Fork) and look at any local changes, stage those, and then commit.

    It’s a convoluted process. But since I haven’t figured out the sync issue it’s what I got.

    Does anyone have any idea what could be wrong with my syncing issue?

    One clue to the issue is:

    In the deployment-process.log file, the last entry says:

    [Sat, 22 Jan 2022 16:58:38 GMT] (i) TRIED AGAIN FAIL: (api) => api.gitdata.createBlob – C:/Users/Tadd.000/Documents/Publii/sites/tadd-mencer/output/amp/going-mobile/index.html
    [Sat, 22 Jan 2022 16:58:38 GMT] ERROR: {“code”:403,”status”:”Forbidden”,”message”:””}

    For giggles, I deleted everything in my Output folder. Start fresh, right? Hit sync. Gets to about 175 of 800ish … and crash, forbidden. Again.

    I’m sure it’s something on my end, but I don’t know what it could be. Testing connection, still says it’s set right. Nothing is showing amiss. But for the life of me, this is making me go bald!!

     

    #6829
    taddmencer

    Didn’t get this figured out, but I just moved my site to Netlify. Worked without a problem. We’ll see if this changes in the future, but if I need better hosting I’ll eventually just … pay for it.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘Error occurred during connecting to github’ is closed to new replies.