We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Featured images of posts on the tags page – using a tag page as the blog page

  • #9105
    Avatar photo[anonymous]

    I have 2 websites both using the Editorial Theme. On both of them, I am using a custom front page and then using a tag page as the blog page to list all my posts.

    I want each post on the tag page to show an image like it does on this demo page

    It works here on this site I made

    but on this site I made, the posts don’t show images.

    I can’t figure out where the setting is. I must have found it once.
    I know the posts have featured images that work because I can see them working in the sidebar.
    It makes me think that there’s a setting I have turned off for showing the featured image on a tags page but I can’t find it.

    Thank you for the help. The more I work on this, the more frustrated I get and then less likely I am to see the obvious thing.

    Avatar photo[anonymous]

    Should be just Theme > Cards > Featured image, tick on.

    Avatar photo[anonymous]

    Thank you. This is my Publii screen.

    Cards is just blankness.

    I did a reset theme settings which got it back — but I now have to try to redo all the other settings.

    OH – I see now, when I change the front page to “selected post” instead of “latest posts” the cards setting becomes invisible, but I can bring it back by changing the front page back to latest posts.

    Now trying to correct all my other settings and see if it works.

    Avatar photo[anonymous]

    Interesting, maybe you found a bug.

    Mine looks like this with Editorial 1.2:

    Avatar photo[anonymous]

    Thank you privii — all fixed now.

    I think the Cards setting disappearing is bug-like.

    I can understand why it goes away since it was originally probably just relevant to displaying cards on the home screen when the home screen showed blog posts. But since it’s also used on tag pages to allow using a static post as the home page, it oughtn’t disappear.

    I guess the issue was the obvious thing. And I looked at it, saw it was blank, and figured that it knew it didn’t apply to me.

    Avatar photo[anonymous]

    At first it looked like I couldn’t post an image to this forum, then it looked like it posted, now it looks like a broken image.

    This is a repeat of posting what it looks like with the Cards setting missing.

    As above – I can get it back by changing the front page setting back to blog. I can then switch it to how I want it. Then change the front page setting back to a specific page.

    View post on