Sign in

Google Analytics Integration Plugin Problem?

  • This topic has 8 replies, 2 voices, and was last updated 3 weeks, 6 days ago by .
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #7800
    Andy

    Hello,

    I’m trying out the new google analytics integration plugin. Unfortunately this one doesn’t work and after research I see that the code to use for the integration is the code “noscript”

    How can we use the classic code with this plugin?

    Thanks in advance,

    #7801
    Bob

    It works very well. I think you are trying to see the code in the preview,  so you should enable the “Output Code in Preview Mode” option → https://getpublii.com/docs/google-analytics.html

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7802
    Andy

    Hello Bob,

    Thank you for the feedback !

    I imagine that I am using the plugin incorrectly.
    I tried both modes:
    In preview mode with the option activated
    In production mode and synchronized on the server side

    I have also tried using the Google Assistant chrome extension but it doesn’t detect anything

    I’m using the gtag.js variant code.
    The code G-xxxxxxx comes from “Data Stream” which is in Google Analytics.
    I have not activated IP Anonymization
    Custom code is empty

    Could you tell me where and how the code normally appears?

    Thanks for your help,

    #7803
    Bob

    any URL?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7804
    Andy

    I was doing my tests with Persona Free theme… (last version)  I tried with other themes and it seems OK.
    Is it possible ?

    #7805
    Bob

    ok, still a problem with the Persona theme?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7806
    Andy

    I think so, if I switch to Technews for example, it works in “Preview” and “Sync mode”. I indeed find the code G-xxxx by looking in the code of the page.

    I just tried again with Persona and there, I can’t find the Google code in the code of the page.

    So I hope it’s just a problem with this theme? I deleted the theme and re-installed it on my computer but the problem remains

    #7807
    Bob

    Could you please provide the live URL for both persona and simple installations?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7811
    Andy

    I found the problem, it was related to my installation because I modified files of this theme to do tests.
    I broke the head.hbs file and the part with this {{{publiiHead}}}

    After uninstalling all of my themes and reinstalling, everything seems OK with all themes.

    Again sorry for the inconvenience for an error that comes from my side

Viewing 9 posts - 1 through 9 (of 9 total)
  • The topic ‘Google Analytics Integration Plugin Problem?’ is closed to new replies.