Sign in

I can’t embed a “button on click” from Mailerlite

  • This topic has 3 replies, 2 voices, and was last updated 3 months, 1 week ago by .
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7214
    chikar

    Hi

    Whenever I try to embed a “button on click” function from Mailerlite, it doesn’t work.

    When I include the code in the code block and click the save button, this turns automatically into this:

    => the whole “button on click” function is erased. The button appears in the post (in my case in the Hero section of the Taste theme), but it is not working.

    If I include the “click on link” function (the one with ahref) from mailerlite, it works, but not “click on button”

    I am new to static site generation, love publii, but I cannot figure out where this comes from. Maybe it’s a basic coding error?

    thanks

    #7236
    chikar

    No one who can help? I hope my question is clear 🙁

    #7311
    Tomasz Dziuda

    Hi,

    Please go to Site Settings -> Advanced options -> Editors -> WYSIWYG editor -> Additional valid elements in the WYSIWYG editor

    and please try to add:

    button[*]

    🙂

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7441
    chikar

    Hi Tomasz, thanks a lot for your feedback, I appreciate it a lot.

     

    I have done what you have proposed, but the problem still persists. I don’t know where I am doing it wrong.

     

    Here is a link to the blog I’m building, you can see that the embed pop up on text works, but embed popup on button click is the same. https://digitalself.pages.dev/

     

    I have included button[*] in advanced options.

     

    But you know what, don’t bother if it is too much of a hustle. It is a nice to have feature, there is always a turnaround. I will use popup on text option, no problem for me.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.