Sign in

Include option: disable sitemap.xsl?

  • This topic has 1 reply, 2 voices, and was last updated 8 months, 3 weeks ago by .
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7013
    Avatar photomarolu

    Hi,
    I’ve been using Publii for a few weeks for a private small blog and I’m very excited about it.
    My question is if there is a way built into Publii to de-activate the xsl for the sitemap layout?

    I normally use my domain without www – however Publii creates the sitemap.xml with an xsl entry on the notation of how the domain was created in Publii.

    <?xml-stylesheet type="text/xsl" href="https://marolu.one/sitemap.xsl"?>

    If there the domain was created with www, there is the xsl entry for wwww in the sitemap.xml.

    If then no (usable) redirection was set up on the webserver, then e.g. google complains that no sitemap.xml can be found.

    I could solve the problem on my Apache server with an appropriate .htaccess.

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^www.marolu.one
    RewriteRule (.*) https://marolu.one/$1 [R=301,L]

    (marolu can only be reached via ipv6)

    However, I think that there are server environments where it is not possible for a website admin to set a rewrite rule
    or a .htaccess – or some people don’t care about a nice sitemap.xml.

    Wouldn’t it be a good option to be able to disable the xsl?
    Can you check this?

    Translated with http://www.DeepL.com/Translator (free version)

    #7023
    Avatar photoTomasz Dziuda

    Hi,

    I do not think it is an issue – if you have such problem, you have a problem with your server configuration not with sitemap. You should always handle www.* prefix properly if it is not used.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.