Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Issue with footer links

  • This topic has 7 replies, 2 voices, and was last updated 1 year ago by .
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9217
    Avatar photojfrere

    When I add an internal link in the footer, I’ve got a strange URL.

    I paste https://mydomain.com/post-title, save the changes. Then when I edit the link again, I got:

    ../../../../../../../../../../post-title

    I did an audit of the website with ahrefs.com, and it tells me that the link ../../../../../../../../../../post-title is a 301 redirect.

    Any help is welcome.

    Thank you

    Julien

    #9234
    Avatar photoTomasz Dziuda

    Hi,

    Are you using relative URLs?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9243
    Avatar photojfrere

    Hi, as I’ve mentioned, I paste the absolute URL.

    https://mydomain.com/post-title

     

    #9244
    Avatar photoTomasz Dziuda

    Hi,

    Regarding relative URLs – do you have enabled Relative URLs under server settings? Sorry that my first message wasn’t too specific 🙂

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9245
    Avatar photojfrere

    No, I didn’t because it says the sitemaps would be disabled if I do so.

    #9250
    Avatar photoTomasz Dziuda

    Ok, thank you for informations – I will try today to reproduce this issue on my local instance

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9261
    Avatar photoTomasz Dziuda

    Hi jfrere,

    I have tested this case and the problem appears only if you put as a link “/post-title” instead of “https://mydomain.com/post-title” – it seems that TinyMCE tries to resolve relative URL to the absolute path.

    I have found that this option: https://www.tiny.cloud/docs/configure/url-handling/#convert_urls is responsible for this behaviour, so we will fix it (by disabling this feature) in Publii v.0.42

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9264
    Avatar photojfrere

    Ok thank you! We’ll wait until the next release of Publii. I’ve managed a workaround with footer menu.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.