We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

JavaScript error main process

  • #1667
    Avatar photo[anonymous]


    after installing I always receive a JavaScript error in the main process.

    The same happens when trying to create a new site.

    Write rights for all folders are ok. Can’t figure out what to do.

    Please advice

    Attached are 2 screenshots (zip file)2020-02-08-10_03_13-Error

    (I deinstalled and reistalled multiple times)

    Avatar photo[anonymous]

    Hi again,

    am I the only one with severe Java error messages. I tried everything but cannot get it up and running. I even disabled Bitdefender (just in case). Nobody with an idea?


    Avatar photo[anonymous]

    I had witnessed this error last year on my windows machine. but got fixed somehow. try this once pls:

    • uninstall app
    • delete publii folder in “C:\Users\Ajeet”  in Windows
    • delete publii folder by going here   <C:\Users\Ajeet\AppData\Roaming>
    • restart machine

    now try installing the app and creating a site. While re-installing, make sure you uncheck the button “create desktop shortcut”.

    Let’s see

    Avatar photo[anonymous]

    Thanks ajeet,

    unfortunately, it did not wor for me.

    I almost give up. I will try every scenario I can think of and let you know.

    Thanks anyhow for your tip

    Avatar photo[anonymous]
    Avatar photo[anonymous]

    Also please try to run Publii as administrator

    Avatar photo[anonymous]

    Also check the above link and try any of the solutions.

    None of the solutions worked for me when i faced the JavaScript issue. The only solution worked for me was the “don’t create desktop shortcut” uncheck while installing publii.. but unfortunately not working for you.

    I had tried the stack overflow link by Tom, but did not help me. Hope it helps you

    Good luck ????