Sign in

Linux Appimage v0.41.x Cannot Change Theme

  • This topic has 7 replies, 2 voices, and was last updated 1 month, 2 weeks ago by .
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8843
    Avatar photoDrinkWater

    Hello, the site’s re-do looks great! Thank you for all your hard work. I’d love to be able to use the new features in 0.41, but neither flavor allows me to change the Theme. I tried working with Simple for a while in V0.41.1 but eventually, it also stopped saving settings. I went back to v0.41, and had the same experience. Thus, I had to go back to 40.3 which allows me to change Themes, work along happily, and properly generate a site. I would greatly appreciate your assistance. I’d be happy to provide you with details of my Linux distro if you would be so kind to share with me how to keep my responses to you private. Thank you, again. I look forward to hearing from someone soon.

    #8844
    Avatar photoDrinkWater

    Ah, I just discovered how to create a private reply with the radio button at the bottom of the post. Also, the .deb does not load the application for me.

    #8845
    Avatar photoDrinkWater

    Additional information for you:

    Also, as usual for Electron apps, I must load v0.40.3 with ” ./Publii.AppImage –no-sandbox ” or else it will not initialize. It works, but there are error messages when it runs:

    [8130:1129/203631.740840:ERROR:bus.cc(397)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
    [8130:1129/203631.741979:ERROR:bus.cc(397)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
    [8267:1129/203632.400450:ERROR:sandbox_linux.cc(377)] InitializeSandbox() called with multiple threads in process gpu-process.
    [8267:1129/203632.757856:ERROR:gpu_memory_buffer_support_x11.cc(44)] dri3 extension not supported.
    [8130:1129/203652.392394:ERROR:bus.cc(397)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
    [8130:1129/203652.461409:ERROR:bus.cc(397)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
    [8130:1129/203652.548711:ERROR:bus.cc(397)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
    [8130:1129/203652.753124:ERROR:bus.cc(397)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
    [8130:1129/203653.036079:ERROR:network_service_instance_impl.cc(978)] Network service crashed, restarting service.
    Set spellchecker to: en-GB
    

    Thank you for your attention.

    #8909
    Avatar photoTomasz Dziuda

    Hi,

    What exactly happens when you tried to save theme settings on v.0.41.1?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8927
    Avatar photoDrinkWater

    Hello, Tomasz. This is what happens: I launch Publii’s AppImage with “Run in Terminal.” I create a new site, select Massively theme (or Blank, Taste, or others), but then the “Save Successful” dialogue box does not appear–no matter how long I wait. This is the error message that happens when the Save Successful dialogue does not appear Publii-15919-error-msg-1 . In making the screenshots I learned that if I close Publii, then the terminal, then relaunch Publii–Massively is now appears as the Current Theme. But that does not always work–this is an error message set when it does not work  Publii-15919-error-msg-2 . Thus I’m left with closing/relaunching/seeing whether or not it saved. So, I’m still using version 0.40.3, but I’d very much like to keep up with the excellent work you are doing! Thank you for your attention.

    #8940
    Avatar photoTomasz Dziuda

    Hi,

    Thank you for your feedback. I have got an information that especially for the newly created websites changing theme directly can not working properly. I will check this issue and I will try to fix it in v.0.41.2

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8947
    Avatar photoTomasz Dziuda

    It seems that I have found a reason – if theme has no saved config then such error occurs. The fix will be added in v.0.41.2

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8954
    Avatar photoDrinkWater

    You are excellent. Thank you very much!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.