We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Linux Mint

  • #797
    Avatar photo[anonymous]


    I downloaded and installed Publii on my laptop with Linux Mint but doesn’t open.

    After I unzip Publii creates two folders usr and opt. In opt it creates another folder Publii and in this folder there is a file named Publii it’s 120MB but Linux says unknown and can’t open it.

    Downloaded the latest version.

    Avatar photo[anonymous]


    Which version are you using – RPM, DEB or AppImage?

    I suppose that for Linux Mint you should use AppImage version.

    Avatar photo[anonymous]

    Hi Tomasz,

    I tried all three and when I run Publii terminal shows the screenshot publii1.png, can’t copy and paste here because Wordfence doesn’t allow.

    So I removed node_modules/sharp then ran npm install and got this publii2.png:

    Thanks for helping


    Avatar photo[anonymous]


    I suppose that it is caused by a missing dependency – please try to do this:

    Then please reinstall Publii.

    Avatar photo[anonymous]


    I already found that page and tried it.

    Avatar photo[anonymous]

    Did this ever get solved? I have a similar problem on Debian 9 with 0.35.3.

    Tried posting detailed outputs to various stages and the Forum rejected my post.