Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Netlify custom domain issue & Simple theme pushes H1 title above page

  • This topic has 7 replies, 4 voices, and was last updated 2 months ago by .
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #11265
    Avatar photojinx

    Hi, I have to say, I found you guys on Jamstack after trying to find Hugo or Jekyll alternative, but with a friendly GUI. Awesome experience and got a website up so quickly. You’ve built the product we all wished dreamweaver was 20 years ago.

    Netlify custom domain issue

    • Netlify will show my custom domain (mycustomdomain.com) on the homepage, but every other page links to my netlify.app link (sample-example-abc123.netlify.app/about-us/)
    • I found someone on netlify’s help forum with my exact problem. He got his publii/netlify site to show custom domain on all links by enabling Server>Website URL>Use relative URLs
    • Given this isn’t mentioned in publii’s netlify config page, this isn’t the proper solution, right? Using relative URLs breaks a lot of publii functioning so its not an ideal solution. Maybe we have both messed up a publii setting or DNS setting?

    Simple theme pushes title on post pages

    • Mobile seems to work fine, but desktop post page titles are so far scrunched up at the top of site that the post date is not visible.
    • It seems to be a problem with changing Theme>Layout>Hero Section>Height from 60vh to 40vh because I desire a slimmer hero section.
    • Is there a setting to just remove H1 page titles out of the hero section and into the page body? It just seems like if you have a long title, even default 60vh is going to cause a problem. Because my About page, for example, oddly doesn’t have this problem.
    • Just for theme feedback, the title being over a featured image doesn’t look pleasing with a lot of images I tested, so a future setting to put the title below the image would be cool.

    I’m using Simple theme 2.8.3.0, the last Windows 7 supported Publii 0.42.1

    Thank you for an awesome product, I’ll be buying themes to support the project.

    #11334
    Avatar photoGyges

    Have you updated the website url in the server settings to your custom domain?

    #11353
    Avatar photojinx
    Gyges wrote:

    Have you updated the website url in the server settings to your custom domain?

    Gyges, thank you. This fixed the links.

    Based on the way the help doc is worded, I was under the false impression Publi required the “sample-example-abc123.netlify.app” format whether or not I had a custom domain or was using Netlify’s .app subdomain.

    I think what compounds the confusion is that Netlify uses those random “sample-example-abc123” names as a sort of identifier even after custom domain setup. But really the “Site ID” is how netlify and publii communicate.

    #11359
    Avatar photoGyges
    jinx wrote:
    Gyges wrote:

    Have you updated the website url in the server settings to your custom domain?

    Gyges, thank you. This fixed the links.

    Based on the way the help doc is worded, I was under the false impression Publi required the “sample-example-abc123.netlify.app” format whether or not I had a custom domain or was using Netlify’s .app subdomain.

    I think what compounds the confusion is that Netlify uses those random “sample-example-abc123” names as a sort of identifier even after custom domain setup. But really the “Site ID” is how netlify and publii communicate.

    You’re welcome, have fun!

    #11363
    Avatar photocandidexmedia
    jinx wrote:

    Simple theme pushes title on post pages

    I didn’t notice this issue in your live site, so I’m not sure if you still need help with this. If so, check out: https://forum.getpublii.com/topic/need-help-with-publii-glitches-in-author-and-tag-descriptions/#post-9889

    If you’re still keen on separating the title from the background image, edit the post.hbs file in your theme site files (see: theme overrides)

    #11394
    Avatar photojinx

    Yes, I figured out a work around last week by adding extra margin for posts that have longer titles. Configured a custom post template:

    publii-forum

    1.) Added a custom css called “hero2” to the main.css file by copying and pasting the “hero” css. Except adding a top margin of 12% so my date and extra long post title are now below the nav bar on desktop and mobile.

    .hero2 {
    background: var(–hero-bg);
    height: var(–hero-height);
    position: relative;
    top: 0;
    z-index: 1;
    margin-top:12%
    }

    2.) Went into config.json and added:

    “postTemplates”: {
    “extramargin”: “extra margin”
    },

    3.) Copied and pasted post.hbs then renamed to post-extramargin.hbs (must be same name as what you put in step 2)

    4.) Changed hero to hero2 in the post-extramargin.hbs file.

    5.) Now on posts where the title is long, I select other options>Post template:>extra margin in post settings for specific posts where I need the extra space for long H1 titles

    6.) Now throw all these new files into simple-override folder so they survive any future theme updates

    https://getpublii.com/dev/theme-overrides/
    https://forum.getpublii.com/topic/can-i-have-selected-post-and-a-blog-page-too/

     

    Alternatively, if you want to remove the H1 post title from displaying in the hero section, do the following.

    Go to post.hbs file and move: div class=”post__meta” & h1
    code to the text body div: div class=”wrapper post__entry”
    then delete: header class=”hero__content”
    then added: padding-top: 4%; and margin-bottom: 4%;
    to the .h1 css in main.css file

    #11396
    Avatar photojinx
    This reply has been marked as private.
    #11406
    Avatar photoTomasz Dziuda
    This reply has been marked as private.
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.