Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Possible bug: Gallery serving full sized images.

  • This topic has 9 replies, 3 voices, and was last updated 10 months, 2 weeks ago by .
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5975
    Avatar photomasonbee

    Fedora: 34
    Publii:   v.0.38.2 (build 14204)
    Theme: Simple

    Imported a WordPress site and I am redoing the galleries as they imported as bulleted images and the gallery images appear to be being served full size.

    To Repeat

    Go to webpage, click on gallery image, lightbox image is the right height and width but is actually the same mb size as the original image.

    Example URL’s

    https://masonbee.nz/153-173-apple-tree-camp/

    https://masonbee.nz/173-198-puketi-recreational-park/

    Actions taken

    I have tried regenerating thumbnails and re-syncing the site. No change.

    #5976
    Avatar photoBob

    It’s not a bug, this is how the gallery works: the thumbnails (low resolution/size) are shown in the post body and loaded in full size when viewed in the lightbox.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #5977
    Avatar photomasonbee

    OK, I need to chop down some images then. I’ll throw the wordpress site back up and work on the Publii one until it is right.

    #9796
    Avatar photoBert2619

    Hello, today I began testing Publii. Well, lightbox does not work with me, when I click on an image the browser shows the image page, and I have to click return to site…Lightbox is enabled…What can I do?

    Btw, I think Publii is beautiful and easy to use (for me).

     

    #9797
    Avatar photoBob
    Bert2619 wrote:

    What can I do?

    I think you should provide more details, like the theme name you are using and the URL of the site where you are having the problem.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9798
    Avatar photoBert2619

    bertkrus.nl
    Here it is. I use Simple theme which came along.

    #9799
    Avatar photoBob

    The gallery scripts and CSS have not loaded; did you modify the theme? If not, please attach the full site backup in a PM.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9800
    Avatar photoBert2619
    This reply has been marked as private.
    #9803
    Avatar photoBob

    Bert2619, I got it.

    You are displaying the post with a gallery on the front page. To make a gallery work well here, you must enable the dedicated option under the Theme Settings -> Front page.

    screenshot-2023-04-13-at-17.37.17

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #9806
    Avatar photoBert2619

    Thanks so much, it works!

     

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.