Sign in

Problem creating post in publli – Javascript issue?

  • This topic has 6 replies, 3 voices, and was last updated 1 year, 10 months ago by .
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #3252

    Hi there, anyone encountered the following issue like me?

    “A Javascript Error occurred in the main process

    Uncaught Exception:

    SqliteError: attempt to write a readonly database…..”


    Same here



    Hi Guys,

    More details please; when exactly it happens: when do you write the first post or the next one? what editor are you using?

    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!


    Did a deinstall of Publii vers 0.36

    Did a fresh install of Publii 0.36.1

    Startet Publii, Add Post screen appears

    Press Button  –> Add New Post

    Enter a title

    Enter a Text “testtext”

    Press Button  –> Save

    Now the Error Message appears as Screenshot above shows



    Sorry , Editor I must figure out, I am currently not familiar with the system 🙁

    Ah found it, WYSIWYG



    Doesn’t work with any of these three Editors (also tried Block and Markdown=



    fiddling around I find the following:

    Deinstall Publii removes the directory :

    C:\Users\Manfred\AppData\Local\Programs\Publii –> as I would expect

    But the following is alive after deinstall:

    C:\Users\Manfred\AppData\Local\publii-updater\installer.exe –> Did not expect to have this on hdd after deinstall


    After all I am not sure why Publii ist installed this way, I would prefer having the programm installed  somewhere i.e d:\  where usually my data are located. Is it possible to leave c:\   untouched, because the operating system sits here?



    Javascript issue solved for me:

    Reason was my Bitdefender Virus Scanner, this software blocked somehow the access to the sqlite database. I don’t know the exact mechanism, but deinstalling Bitdefender helped to get Publii working.  Works like a charm 🙂 Sorry for any circumstances.

    Best wishes!


Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.