Sign in

Problem with Google Search Console

  • This topic has 6 replies, 3 voices, and was last updated 4 days, 13 hours ago by .
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #8371
    Avatar photoMarkusAllen

    First of all, this is my first post. I absolutely LOVE Publii.

    In fact, I’ve been blogging daily – coming up on 30 days in a row.

    Now:

    Google isn’t indexing a lot of my tags.

    And I see why. For some reason, I have this in the <head> of each tag page:

    <meta name=”robots” content=”noindex, follow”>

    I don’t think I have noindex turned on…

    Can someone point me in the right direction to fix this universally through my blog?

     

    #8373
    Avatar photoshaun2k

    Noindex can be turned on/off from Site Settings>Advanced Options >SEO

    Take a look at https://getpublii.com/docs/website-settings.html#seo

    #8374
    Avatar photoMarkusAllen

    Noindex can be turned on/off from Site Settings>Advanced Options >SEO

    Take a look at https://getpublii.com/docs/website-settings.html#seo

    I have noindex turned off.

    It only shows a noindex on tag pages – not on content/blog pages.

    Any other ideas?

     

    #8375
    Avatar photoMarkusAllen

    A quick FYI I forgot to say in my original post:

    One of the greatest gifts I learned from suffering with WordPress was tag pages.

    They are HIGHLY rewarded on Google.

    The vast majority of my organic traffic came from blog tag pages.

    CleanShot-2022-09-20-at-14.34.40

    As we can see, Google is holding back… all because Publii is adding this in each tag’s header section:

    <meta name=”robots” content=”noindex, follow”>

     

    #8379
    Avatar photoBob

    There are two places where you can manage robots meta tags: in Site settings -> SEO and in Tag manager.
    Check both. I’m sure NOindex is set in one of them.

    screenshot-2022-09-20-at-20.46.26

    screenshot-2022-09-20-at-20.46.54-1

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8385
    Avatar photoMarkusAllen

    There are two places where you can manage robots meta tags: in Site settings -> SEO and in Tag manager.

    Check both. I’m sure NOindex is set in one of them.

    screenshot-2022-09-20-at-20.46.54

    Ah ha. There it is (by default). Thank you!

    Suggestion for the future: make “index, follow” the default. Google will reward us as a result.

    #8387
    Avatar photoBob

    Suggestion for the future: make “index, follow” the default. Google will reward us as a result.

    In most cases, the tagged pages contain the same content – a post listing,  that the search engine can treat as duplicate, thin content. This is why Publii sets noindex to all of them by default.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.