Sign in

Problem with webp

  • This topic has 3 replies, 2 voices, and was last updated 9 months, 3 weeks ago by .
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6885
    Avatar photopapenbka

    I don’t know if this is a bug or a feature.

    I upload images in jpeg format to the website. Everything works well.
    I tried to upload images in webp format, but they are not visible.
    I tried disabling responsive images in site settings\Website speed\Enable settings.
    In this case, webp is visible, the featured picture (in jpg) in the post is visible, but the jpg images in the gallery are not visible (they load if you click on them).

    The theme is Taste (2.1.0.0 v.)
    The site is hosted on Netlify. Some post-processing plugins are enabled. I tried to disable them, but it didn’t help.

    Your thoughts?

    Still, upload png and jpg to the site and not try webp?

    #6886
    Avatar photopapenbka

    Oh, I found a similar topic  and it says that webp support has been added.
    But I have the latest version of Publii v.0.38.3 (build 14238) and windows 7
    What am I doing wrong, it would be interesting to know.

     

     

    #6910
    Avatar photoGyges

    This is probably about the chosen image resize engine, Jimp doesn’t have webp support, Sharp does, but Sharp has issues.

    Sharp is not available for Linux, though. Don’t you about Macs.

    Attachments:
    #6912
    Avatar photopapenbka

    This is probably about the chosen image resize engine, Jimp doesn’t have webp support, Sharp does, but Sharp has issues.
    Sharp is not available for Linux, though. Don’t you about Macs.

    Oh, thank you!

    Didn’t know about this setup. I’ll try to turn on Sharp.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.