Sign in

Publii 0.39 Appimage not working: Illegal instruction (core dumped) error.

  • This topic has 6 replies, 2 voices, and was last updated 8 months, 2 weeks ago by .
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7077
    Avatar photoMoltke

    Hi, I just downloaded Publii-0.39.0.AppImage, and when I tried launching from terminal(I always do this at first, just to make sure appimages work as expected before integrate them into the system)got this error: Illegal instruction (core dumped), and it doesn’t start. V0.38 stills works fine. Any help/advice is greatly appreciated.  🙂

    System Info:

    Operating System: KDE neon Testing Edition
    KDE Plasma Version: 5.24.3
    KDE Frameworks Version: 5.93.0
    Qt Version: 5.15.3
    Kernel Version: 5.13.0-35-generic (64-bit)
    Graphics Platform: X11

    #7078
    Avatar photoMoltke

    I downloaded and tried with the .deb to no avail, same error. 🙁 So it’s not just the appimage.

    #7079
    Avatar photoTomasz Dziuda

    Hi,

    Publii v.0.39 again contains the sharp library as earlier linux build was unable to support WebP.

    The problem most probably is related to your processor: https://github.com/lovell/sharp/issues/2723#issue-894046354

    Do you one some older CPU model?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7081
    Avatar photoMoltke

    Hi,

    Publii v.0.39 again contains the sharp library as earlier linux build was unable to support WebP.

    The problem most probably is related to your processor: https://github.com/lovell/sharp/issues/2723#issue-894046354

    Do you one some older CPU model?

     

     

    Hi, thanks for your reply. Old CPU? Well, is this one:

    Processors: 2 × AMD E-300 APU with Radeon(tm) HD Graphics
    Memory: 5.4 GiB of RAM
    Graphics Processor: AMD PALM

    #7092
    Avatar photoTomasz Dziuda

    Well, it is 11 years old processor, so it is quite possible that it is incompatible with sharp library 🙁

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7093
    Avatar photoTomasz Dziuda

    In this case I can only recommend to use previous version without sharp, and I will check if it is possible to build an app (in v.0.40) which conditionally loads sharp library only if the specific processor instructions are available.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #7094
    Avatar photoMoltke

    In this case I can only recommend to use previous version without sharp, and I will check if it is possible to build an app (in v.0.40) which conditionally loads sharp library only if the specific processor instructions are available.

    Oh, well, thanks for your help. I’ll keep on using v0.38.3.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.