Sign in

Publii and Balena Etcher

  • This topic has 4 replies, 4 voices, and was last updated 7 months, 1 week ago by .
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6554
    Avatar photoCesar

    Hi there.

    Running Publii on  Ubuntu 20.04 with Balena Etcher installed makes Publii try to open a preview with Balena Etcher instead of opening the default web browser.

    Both apps (Publii and Balena Etcher -> https://www.balena.io/etcher/) are based on Electron. So how could I solve this issue?

    How can I open a Publii preview with my default web browser without removing Balena Etcher from my system?

    Thanks in advance and best regards.

    #6556
    Avatar photoTomasz Dziuda

    Hi,

    As Publii tries to open HTML file, maybe this app is marked as a default app to open *.html files? Or it is a default app to open file:// protocol on your system?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6564
    Avatar photoCesar

    Hi.

    Balena Etcher is an app oriented to flash OS images to SD cards & USB drives.
    It has nosense having this app as the default one to open html files. In fact, and even though Firefox is my default app to open html files, Publii tries to open a page preview with Balena Etcher.

    If I remove from my system Balena Etcher Publii works fine rendering a page preview properly (opening the web browser).

    So, the question is: which app is working badly? Publii or Balena Etcher. As a simple user, I don’t have a simple way to find it out.

    My kindly request to Publii developers is: could you, please, try to reproduce this Publii behaviour with Balena Etcher installed?
    My setup: Ubuntu 20.04 x64 + Gnome under Xorg + Publii 0.38.3 (from deb file) + Balena Etcher 1.5.117 (from deb file).

    Thanks and regards.

    #6899
    Avatar photodjfdat

    I think your best bet is to make a blank.html file, right click and check it’s properties/open with and make sure the default is set to a web browser. This is probably not a Publii nor a Balena Etcher problem, but an issue with your OS config.

    It may however be nice to specify which application to use inside of Publii in general. But that should probably be a separate feature request if it’s not already.

    #6950
    Avatar photoGyges

    I tested on Manjaro with latest Etcher installed, cannot reproduce.
    Maybe a configuration issue?

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.