Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Publii error message

  • This topic has 2 replies, 2 voices, and was last updated 3 years, 4 months ago by .
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #3901
    Avatar photoAntonio

    Hello to all.
    I have a problem, I updated Publii to version 0.37.1, but after updating also the themes to the latest version, an error message appeared, and the theme was not updated for the site I was working on.
    I tried to uninstall Publii and install the previous version but at startup the message appeared again and the application goes in crash.
    I made several tests with both the new version and the previous one but it is no longer possible to use the application because it crashes every time.
    I also tried to clean up the personal folder with the site but nothing has changed.
    I have the latest version of MacOS (Catalina 10.15.7).
    Thanks in advance for your help.
    This is the message:

    A JavaScript error occurred in the main process
    Uncaught Exception:
    Error: ENOENT: no such file or directory, mkdir '/Users/antonio/Documents/Publii/themes/simple'
    at Object.mkdirSync (fs.js:823:3)
    at App.checkThemes (/Applications/
    at new App (/Applications/
    at App.<anonymous> (/Applications/
    at App.emit (events.js:215:7)
    at App.EventEmitter.emit (domain.js:476:20)
    at App.topLevelDomainCallback (domain.js:131:23)


    Avatar photoBob


    Unzip the Simple theme and move the “simple” folder with its contents to the following location:


    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    Avatar photoAntonio

    I’ve recreated the folders for “themes” (with “simple” inside), “config” and “sites” and now works.
    Many thanks for your help.


Viewing 3 posts - 1 through 3 (of 3 total)
  • The topic ‘Publii error message’ is closed to new replies.