Sign in

Publii hotfix 0.38.3 released!

  • This topic has 7 replies, 6 voices, and was last updated 1 month ago by .
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6116
    Bob

    The hotfix 0.38.3 has been shipped to address bugs found in Publii and reported by our fantastic community since the latest release.

    The full list of improvements can be found below:

    1. Added fallback for the image dimensions in the theme config. The lack of these dimensions could have blocked the thumbnail regeneration process.
    2. Sharp’s image resizing engine will not remove image metadata when generating thumbnails to preserve the rotated image metadata
    3. From now on, duplicate websites will have cleared deployment settings to avoid situations where changing deployment settings under duplicated page changes original site deployment passwords
    4. Fixed a bug where it was not possible to go back to the centered gallery layout
    5. Fixed issue with missing CSS has-submenu class for menu items when generating menu output
    6. Fixed visual glitch on Linux for the WYSIWYG editor dropdown with text styles in the dark mode
    7. Removed italic from image/gallery captions to stay consistent with the real output where there are no italic styles for these elements
    8. Removed the CMD+H shortcut in Mac OS for the markdown editor to allow this shortcut to be used to hide the window

     

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6450
    masonbee

    Very minor detail and so messy on my end that it probably isn’t worth investigating ๐Ÿ™‚

    Kubuntu 21.10, Publii deb

    When trying to change the password it accepts the change but if the Gnome keyring isn’t open it then errors when trying to upload (I think because the password hasn’t actually changed). However the appimage (same release) does say the keyring hasn’t been opened. Also, after having changed the password in the appimage version (with the keyring open) if i swap back to the deb version it now shows the correct password and uploads fine.

    But like I said, it’s probably not worth investigating unless to check whether the deb asks whether the keyring is open on startup….and it could be something else. 21.10 is only a couple of days out at the moment. On the bright side the appimage seems to work flawlessly on it and the deb as well once I had opened the keyring.

    #6452
    Andy

    For point 3:
    The problem is still here.
    I am using netlify and if I duplicate a site and change the “Token ID site” the change is on both. The original but also the copy

    #6517
    Mathias

    Just wondering: how’s development getting along? What’s the next big step being prepared? Plugins?

    Anyway: for as far as I’m concerned, Publii fulfills all my needs. I’m 100% happy ๐Ÿ™‚

    Congratulations once again and keep up the good work, Publii developers!

    #6519
    Bob

    Hi Mathias,

    Yeap, plugins ๐Ÿ™‚ We are working on this for a while and also on a multilingual app interface. In addition, we update many things like an electron or Tiny editor and many other elements.
    I think that the first “plugin release” will come out in December.

    Earlier, we will release a new theme which is almost finished, notice also, two days ago we released an update of all free themes.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6525
    cumlaude

    Earlier, we will release a new theme which is almost finished, notice also, two days ago we released an update of all free themes.

    The config.js of the TechNews theme mentions the previous version (2.3.0.0) instead of the new one (2.3.1.0).

    Attachments:
    #6527
    Bob

    The config.js of the TechNews theme mentions the previous version (2.3.0.0) instead of the new one (2.3.1.0).

    My fault, sorry. Fixed and ready to download now https://marketplace.getpublii.com/product/technews/

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6533
    candidexmedia

    For point 3:

    The problem is still here.

    I am using netlify and if I duplicate a site and change the โ€œToken ID siteโ€ the change is on both. The original but also the copy

    Andy, is this still happening?

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.