Sign in

Rendering Never Finishes

  • This topic has 19 replies, 4 voices, and was last updated 1 week, 4 days ago by .
Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #6326
    imeanhonestly

    Upgraded to Publii 0.38.3 and now none of my sites will render. Even a new test site won’t render.

    Selecting preview changes opens the rendering dialog and then nothing else happens. I can see Publii drive my CPU usage up in Windows Task Manager, but it never finishes and there is nothing in the logs. The progress bar never moves. None of my 3 sites are at all large, and the test site has a single post.

    I don’t even know where to start.

    #6327
    Tomasz Dziuda

    Hi,

    Please check if you have anything under Tools -> Log viewer -> rendering-*.log files

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6329
    imeanhonestly

    Hi Tomasz, there is nothing in the logs. It’s like the rendering never starts.

    #6333
    imeanhonestly

    Ok. Uninstalled, deleted directories in /user, though there are clearly still some settings being saved somewhere.

    With what should be a clean install, and a new site, when trying to render a test post I get:

    Rendering process failed
    An error occurred during rendering process:
    EPERM: operation not permitted, rmdir 'C:\Users\username\Documents\Publii\sites\test3\preview\media\authors'

     

    The rendering error log is empty.

    Is that helpful? I’m happy to walk you through it in more detail.

    Otherwise, I think I just need to abandon this platform.

     

    #6334
    kensquires

    @imeanhonestly – okay you have me curious about your problems.. I am just an average user like you.. So I see your using windows atleast I know the system since that’s what I’m using..

    But I have to ask for you to do something for me…

    Goto Documents / Publii / Sites / (insert your site name)

    and zip that up and upload it to OneDrive or some free filehosting site and post a private reply (unless you want it public then your choosing) with the link to those files.. I want to see if I can help

    #6338
    imeanhonestly

    @kensquires – I appreciate the interest, thank you. I’m happy to do that, as I get the same issue with a clean install and a brand new test site with a single test post. But that also makes me think that it’s not particular to the site or those files, but some weird windows incompatibility or permissions issue.

    I’ve tried running Publii as admin (right click, run as admin), and that doesn’t seem to make a difference.

     

    #6339
    kensquires

    @imeanhonestly – I don’t think it’s windows nor an admin problem.. I’m not running it doing the admin thing that you mentioned. Not to mention I’ve had it run on win10 and right now I’m testing win11 and it’s still running great, I’ve even backed up my sites to a external drive and moved them back without issues

    Okay hold up, I had this dumb ass idea (apologize if anyone is offended by my choice of words) .. but I want you to open Publii .. Choose a site it doesn’t matter what one..
    Click on – site settings
    what current theme do you have ?

    #6341
    imeanhonestly

    I’m having this issue with a clean install, new site, and single test post on the default theme.

    #6342
    kensquires

    The only thing I can say is zip up your site as I mentioned above and post it, maybe it’s something minor your overlooking.

    I wouldn’t exactly count publii out, we’re just searching for more information to help

    #6353
    Tomasz Dziuda

    @imeanhonestly – this issue still appears after Publii restart? I mean:

    • create website
    • restart Publii
    • try to render the previously created website

    I suppose that you run into quite random bug which I have seen sometimes on my mac OS, but it is really hard to debug as it occurs quite randomly for me and when I do not expect it so it is heavy to restore the way which leads to this error.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6354
    imeanhonestly

    Yep. I can restart and get the same issue.

    I can uninstall. Delete all the directories. Reinstall. Create a new test site and still have the same issue. Which is to say, I cannot get the latest Publii to work on my Win10 desktop. I’m confident it’s not a theme issue, or particular to my content as it happens with a clean install on a new site.

    I’m currently getting around this by installing Publii on a Mac, and using an older backup. When I have a few mins I’ll create a new backup from that, and try and migrate that to the PC. See if that works.

    #6355
    Tomasz Dziuda

    And do you always get the same EPERM error for the authors directory?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6356
    imeanhonestly

    I get that error on the first preview on a new site after a clean install, but then never again.

    #6357
    Tomasz Dziuda

    @imeanhonestly

    So the problem with rendering is solved now or there is other issue?

    Regarding the error occurrence for the newly created websites – I will need to check this problem again, maybe I will be able to reproduce it and find a reason of the error message/

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6360
    imeanhonestly

    Sorry, to be clear, I get the eperm error on first preview of a clean install on a new site, and then I never see the error again. After that first run where that error pops up, every subsequent rendering never works, and there is no error.

    I can replicate this reliably. Happy to show you via zoom. Have partially solved the issue by installing Publii on a different computer, but would prefer to run it on my main machine.

     

    #6387
    Jampi

    Hi!

     

    I have a similar issue, both in preview and in sync mode.

    Rendering process failed
    An error occurred during rendering process:

    EPERM: operation not permitted, rmdir ‘C:UsersUtenteGoogle DrivePubliiSitesvisa-worldoutputmediaauthors’

    Once I had this windows dialog error:

    Publii_error

    This happens to all my Publii Sites 😥

    My last Sync is 23rd of September. The only thing changed is that I had to switch to “Google Drive” from the old “backup and sync”.

    I tryied to copy the input folder to a new path (no cloud storage) but the result is the same…

    I’ll be very frateful to have some help.

    #6396
    Tomasz Dziuda

    @jampi

    Could you try to remove contents of the site output directory (I mean output catalog in your problematic website directory)? It should be something like publii/sites/SITE_NAME/output/ – clear content of this catalog.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6402
    Jampi

    Already done, when I try to sync or launch a preview it stucks at 80%, when coping files.

    Now I got a new problem, websites are no more displayed in the website list…

    I’m sure the problem is caused by google drive.

    #6403
    Tomasz Dziuda

    I afraid that it is connected with a way how Google Drive files are visible for apps :/ If I correctly remember sometimes files are visible but not already downloaded what leads to an unexpected behaviour 🙁

    The only thing which I can advise at this moment is try to use local storage for website files.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #6411
    Jampi

    Hi Tomasz,

    problem solved:

    • Transfered the website folder to a local one (no cloud storage)
    • Made a backup of the website
    • Created a new site
    • Transfered the backup file of compromised website to the backup folder of the new one
    • Restored from tools > Backups

    For a couple of them I had to insert server credentials again, but it just works fine.

    Have a nice day!

Viewing 20 posts - 1 through 20 (of 20 total)
  • You must be logged in to reply to this topic.