Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Server setiings aren’t being saved.

  • This topic has 3 replies, 2 voices, and was last updated 2 years, 11 months ago by .
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #5137
    Avatar photoMoltke

    Hi everyone! Hope you’re all having  nice life! 🙂

    First time posting here. I also posted a comment here I’m using the appimage. Basically, after going through all the Publii and GitHub pages configuration when I click on “Save Settings” nothing happens. The connection test succeeded

    In the docs, I noticed that it says: Protocol – Select Github Pages from the drop-down list. Well, I don’t get that option, all I can see is

    API server: 

    My system is Debian Buster with KDE. In that same github issues page another user said using the .deb file didn’t work for him either. Any advice/help is really appreciated. Thanks in advance for all your answers. 🙂

    Avatar photoMoltke

    Thanks to another user who posted the solution here it’s fixed and publii works fine now. Turns out some keyring manager is needed, I use KDE but have the wallet disabled, I don’t use it. The suggested solution was to install


    and it worked. Now I wonder if enabling KDE wallet will have the same effect. I’ll try and let you know. I think, There should be something in the docs stating that, “If you have problems to configure the server, make sure there’s a keyring manager available on your system” or something like that.

    Avatar photoTomasz Dziuda


    I will try to address this issue in the next release:

    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    Avatar photoMoltke
    Tomasz Dziuda wrote:


    I will try to address this issue in the next release:

    That’d be nice! Thanks for your work. By the way, I recently installed Debian in another machine with KDE too. I tried enabling Kwallet and see if that made the trick, unfortunately it didn’t. It seems one has to explicitly install gnome-keyring to make it work, after doing so, publii works. Thought you might want to know that.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.