Sign in

SFTP | Please check file permissions on your server (still having problems)

  • This topic has 2 replies, 2 voices, and was last updated 2 weeks ago by .
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #8778
    Avatar photoSashag

    Hey y’all,

    I have a problem with sftp deployments. My configuration is:

    • MacBook Pro M1 running Ventura
    • Using sftp but with an ssh key
    • Server is a bare metal machine that I administer myself (I’m doing Unix admin stuff for some 25 years now …)

    I have this problem also with sites that <span style=”text-decoration: underline;”>worked before</span> this update. What I already checked:

    • Remote path is correct and writable
    • Key file is correct and ssh login is working
    • Don’t use any protocol prefix, just the server’s IP

    Now I’m out of clues.

    Cheers, Sasha

    #8792
    Avatar photopublii-slpa

    I had a similar problem using FTP. I was not able to find the issue. Like you said, the permissions and what not were all correct.

    Finally, I threw a “hail Mary” and deleted all the files on the server and uploaded the site from scratch.

    That worked for me. Worth considering.

    Cheers!!

    #8811
    Avatar photoSashag

    Hey,

    found the reason for the problems:

    My server uses a pretty new openssh version (8.9). And I’m a lazy person and still use RSA keys. But since openssh 8.8 RSA is not enabled by default anymore (deprecated for security reasons).
    So while you could switch it on again in the sshd config file, the better way is to make the clients use a more modern algorithm, like ed25519.

    When doing this, everything works again. So it never was a problem caused bei Publii 👍

    Cheers, Sasha

Viewing 3 posts - 1 through 3 (of 3 total)
  • The topic ‘SFTP | Please check file permissions on your server (still having problems)’ is closed to new replies.