Sign in

SFTP | Please check file permissions on your server

  • This topic has 5 replies, 2 voices, and was last updated 2 weeks, 2 days ago by .
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8308
    Avatar photoSTEVE

    Hello, I set up SFTP, but when testing the connection I get the following error asking me to check file permissions on your server:

    https://markuphero.com/share/XTYyDbbcd8GDddbuvmmL

    These is the settings for SFTP. Am I doing something wrong?

    https://markuphero.com/share/Sxk2uFmCCyI1h9K15AsL

     

    Thanks!

    #8309
    Avatar photoTomasz Dziuda

    Hi,

    Publii during connection tries to store and remove test file – the mentioned error appears when Publii is able to connect to your server but is unable to add/remove file from the provided location.

    So your problem is caused by:

    1. Invalid remote path – maybe it should be relative to location when you are landing after successful log in via ssh
    2. Typo in the remote path – so Publii tries to store files in the non-existing catalog
    3. Invalid ssh user permissions

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8312
    Avatar photoSTEVE

    Hello again. I am still unsuccessful in connecting my server.  I shared your suggestion with my hosting support and they suggested I try several variations of the remote path, and none worked. Then they suggested the following:

    “As the Publii support mentioned SSH user permissions, it might be needed to enable SSH access.
    This can be done via the “Manage Shell” cPanel menu: https://www.namecheap.com/support/knowledgebase/article.aspx/10040/2210/how-to-enable-ssh-shell-in-cpanel/ .”

    So I tried that and it’s still not working.

    Please help.

    Thanks,
    Steve

    #8313
    Avatar photoTomasz Dziuda

    Do you can find anything useful under Tools -> Log viewer ?

    To be honest – I have no idea what is the reason of your problem – I suspect strange server configuration which is incompatible with Publii SSH library.

    Alternatively you can use manual deployment or FTPS protocol.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8316
    Avatar photoSTEVE

    PROBLEM SOLVED!

    My hosting support tested it on their end and determined that in the Server field I had to remove the sftp:// from the server URL.

    I tested on my end and it’s now syncing!

    Thanks for your patience and I hope this post helps others who might face the same trouble.

     

    STEVE

    #8317
    Avatar photoTomasz Dziuda

    Great news! 🙂

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘SFTP | Please check file permissions on your server’ is closed to new replies.