We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

SFTP Stuck

  • #478
    Avatar photo[anonymous]

    Hi, I synced my website to my hosting company (FastComet) successfully via FTP but via SFTP it get stuck (see print screen)
    By the way the Test connection button is OK with SFTP
    Any idea?
    Thank you

    Avatar photo[anonymous]


    Please check your logs under Tools -> Log viewer, maybe there is some useful information about your issue.

    Avatar photo[anonymous]

    Thanks Tomasz, which one can I send you?

    Avatar photo[anonymous]

    Please attach first 8 ones and the last one.

    Avatar photo[anonymous]
    Avatar photo[anonymous]

    Could you check if your SFTP account has proper permissions to access your files on the server?

    Could you also check if the path provided in your server settings is ok?

    I suppose that it must be permission or path issue as Publii cannot find the files.remote.json file during SFTP session.

    Avatar photo[anonymous]

    I tested the connection and the connection is working fine

    Also I received this reply from FastComet hosting

    Upon investigating the matter, it appears that your IP XXXXXXXXXXX is not blocked on any of our firewalls.

    We tried to access on our end and we were successful:

    fastcomet5[anonymous]~$ ssh -pXXXXX XXXXXXXXXXXXXXXXXX
    XXXXXXXXXXXXXXXX’s password:

    Any extra idea?


    Avatar photo[anonymous]

    Please set option “Remote path” to an absolute path on your server e.g. /var/www/

    Avatar photo[anonymous]

    You can also try to set “Remote path” just to “/”

    Avatar photo[anonymous]

    Thank you Tomasz, it is working with the absolute remote path

    Avatar photo[anonymous]

    Thanks to @Tomasz and @nilsvb.

    Setting the “Remote path” to an absolute path worked for me too.

    Though I needed to also set the port to the correct port number specified by my web host, rather than use the default 22.