We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Spinner for loading does not stop for Publii website

  • #3215
    Avatar photo[anonymous]

    I’ve set up a website using Publii.  The site appears normal on most browsers (i.e. Edge, Firefox) except for Google Chrome, where a loading “spinner” does not stop on the main page.

    Here is a link to the website:

    Is this a problem with my configuration, or is there an underlying issue?  I’m not certain where to look to debug this issue, could someone point me in the right direction?

    Avatar photo[anonymous]

    Here is a picture of the spinner that does not go away.

    Avatar photoBob

    There is something wrong with your images, so try to remove the “empty images” or upload them again.


    Avatar photo[anonymous]

    Hi Bob, thanks for your help.  As far as I know, there are no images on the site associated with each of the cards.  Would adding images be suitable for changing this?

    Avatar photo[anonymous]

    The stuck spinner does not appear when I try to preview the site locally on my computer, and the problem seems to occur only when the Publii site is pushed to the server.

    Avatar photo[anonymous]

    Might it be useful to delete all of the site content from the server and then try to re-upload the entire site from within Publii?

    Avatar photoBob

    Finally, I found a bug, I forgot to add checking if the image exists.

    Download the new version and update your installation

    Avatar photo[anonymous]

    Again, thanks so much for your help, Bob.

    I installed the new theme and tried regenerating thumbnails by switching the theme and then switching back to another theme in the site settings.  The Mercury theme is being used.

    Unfortunately, the spinner still persists on the server when viewed using Chome.  Another browser (Edge) does not show the spinner.

    I also tried to delete all of the files generated by Publii and re-uploaded to the server again.  The spinner still persists.

    What I am doing wrong here?

    Avatar photo[anonymous]

    After adding a post or two, the problem with the spinner is still being manifested.  Is there an image that I need to add or change on the publii site?


    Avatar photo[anonymous]

    I think this might actually be a Chrome bug, since the problem with the loading images only occurs when there is no featured image added to the posts.  Other browsers such as Edge do not show the spinner.

    I’ve tested this with Chrome on Mac OS X and Windows 10.  The problem still persists.

    So what I did was add featured images to each of the posts on the site.  The spinner does not appear.

    I am closing the topic since the problem is now resolved.  Hopefully this will help to further development.  Thanks again for your help and support.