Sign in

Taste theme, svg icons are not showing in deployed version

  • This topic has 6 replies, 2 voices, and was last updated 2 weeks ago by .
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5159
    Yaroslav

    Hi friends and developers! I am very inspired using Publii. Thanks to developers once again)

    On my site I am using Publii Taste Theme. On localhost everything works great. Then I deployed my site to Netlify. Everything works corrrect besides svg theme icons. It concerns all default icons (search, social, comments).

    Can you help me to understand where I need to fix it?

    #5160
    Bob
    Support

    Most likely there is a problem with the non-HTTPS and HTTPS domain URL. Check what you set in the domain field (server configuration) and what URL you enter in the browser.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #5161
    Yaroslav

    Hi Bob! Thank you for such fast answer. I deployed website using server tools in Publii and using Netlify. In Netlify settings in Publii Server tools website url is https. When entering browser, there is also https. I did it step by step using Publii documentation “how to build a static website with Netlify” Can it be a problem of subdomain name of website “siteName.netlify.com” ?

    #5162
    Bob
    Support

    If your site URL is https://siteName.netlify.com, set exactly the same domain name in the server settings.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #5163
    Yaroslav

    If I understood you correct, my server settings are correct from the beggining. Are you talking about this settings? It was set exactly this way from the beggining, but svg icons are not shown

    Attachments:
    #5165
    Bob
    Support

    Your website is available in the travelchem.netlify.app domain, but the assets files (including the svg.map) in the travelchem.netlify.com

    So, change the domain in the server settings to netlify.app

    PS: nice looking site!

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #5166
    Yaroslav

    What a stupid mistake from my side. Sorry Bob, for taking your time for so long) Now everything is working!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Taste theme, svg icons are not showing in deployed version’ is closed to new replies.