Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Using Block Editor

  • This topic has 5 replies, 4 voices, and was last updated 6 months, 3 weeks ago by .
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10449
    Avatar photooleteacher

    Greetings. Testing Publii for some classroom blogs.

    Got an email about the “Syntax Highlighter Plugin” and trying it out. Could not get it to work and then noticed it only works with block editor.

    We chose the WYSIWYG editor since younger kids will be using the software.

    Now I cannot seem to activate the block editor on a new post?

    #10452
    Avatar photocandidexmedia

    Hey there!

    Here’s how you activate the Block Editor:

    access-new-posts-types

    Publii remembers the last used editor when creating a new post, but that can always be changed.

    In terms of using the Syntax Highlighter with the WYSIWYG editor with syntax highlighting, check out this thread (the workaround is a PITA, but works if you absolutely need to use that editor): https://github.com/GetPublii/Publii/issues/1084#issuecomment-1374725049

     

    Best of luck with your class, and please share any findings! I’d love to get some insight from a fellow educator. ๐Ÿ™‚

    #10455
    Avatar photoBob
    oleteacher wrote:

    Could not get it to work and then noticed it only works with block editor.

    I have good news for you. We will add a solution to the WYSIWYG editor that will completely change the way you input code in this editor. This will be included in the upcoming Publii release, most likely this month.

    screenshot-2023-08-10-at-11.13.43

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #10458
    Avatar photooleteacher
    candidexmedia wrote:

    Hey there!

    Hereโ€™s how you activate the Block Editor:

    access-new-posts-types

    Publii remembers the last used editor when creating a new post, but that can always be changed.

    In terms of using the Syntax Highlighter with the WYSIWYG editor with syntax highlighting, check out this thread (the workaround is a PITA, but works if you absolutely need to use that editor): https://github.com/GetPublii/Publii/issues/1084#issuecomment-1374725049

    Best of luck with your class, and please share any findings! Iโ€™d love to get some insight from a fellow educator. ๐Ÿ™‚

    Very good info, thank you very much!

    The workaround for WYSIWYG is indeed a pain. Can’t see having the time to teach this to younger kidos.

    #10459
    Avatar photooleteacher
    Bob wrote:
    oleteacher wrote:

    Could not get it to work and then noticed it only works with block editor.

    I have good news for you. We will add a solution to the WYSIWYG editor that will completely change the way you input code in this editor. This will be included in the upcoming Publii release, most likely this month.

    screenshot-2023-08-10-at-11.13.43

    Thanks Bob! Will keep an eye for the update.

    #10465
    Avatar photokarlchen

    Bob, thist will be usefull addition , looking forward to the update,

    keep up the good work, Axel

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.