Sign in

WP Import not working :-(

  • This topic has 13 replies, 2 voices, and was last updated 1 week, 4 days ago by .
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #8635
    Avatar photoeranm

    I just upgraded to 0.41.0 (in case an older version was causing this problem) but the WP import is still not working.

    It finds the XML file that WP exported and it begins the import, but it then just sits there with the screen slightly greyed out (as if it’s working on the import), but then nothing…

    It just isn’t completing the import.

    BTW, not sure if it makes a difference but the XML file (exported from WP) is only 1906KB in size, which is a lot smaller than I expected.

    Does this mean the WP export is broken and its not fully exporting everything OR is that a reasonable file size and (perhaps) it just takes a long time to import a site?

    Any assistance anyone can provide would be greatly appreciated.

    #8642
    Avatar photoTomasz Dziuda

    Hi,

    Could you share your WXR file in a private reply?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8643
    Avatar photoeranm
    This reply has been marked as private.
    #8650
    Avatar photoTomasz Dziuda

    I have checked your WXR file and I was able to import it without any problems on Publii v.0.41, but it takes longer time, because ~250 images must be downloaded.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8651
    Avatar photoeranm

    Hi Tomas. I figured it might take a long time due to so many photos, but I have literally left it running for more than an hour trying to import and that didn’t seem to help at all.

    How long should I wait?

    #8654
    Avatar photoeranm

    Ran it again. It sat there for 5 hours, and nothing changed.

    #8655
    Avatar photoTomasz Dziuda
    This reply has been marked as private.
    #8656
    Avatar photoeranm

    I have downloaded the file, but how do I install it? I am on a PC so I don’t normally use TAR files, just ZIP.

    Thanks in advance for your help.

     

     

    #8657
    Avatar photoTomasz Dziuda

    You have to click on the website name, then click to “Add new website” and select tab “Install from backup”

    create-from-backup

    There you can just drag’n’drop the TAR file which you have downloaded

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8667
    Avatar photoeranm

    Ah ok, cool. So is this a better way to import all future sites?

    And how do you get a backup of a site AND make it a tar file?

    Is that the same as doing an export and grabbing the XML file?

    BTW, how long should an install from backup take? It’s been sitting there with the “wheel” rotating for at least 15-20 mins now.

    Not sure if it just takes a long time or whether something is broken.

    I did get some kind of javascript error just after I starting it but it kept going (see attached screenshot)…

    Attachments:
    #8669
    Avatar photoTomasz Dziuda

    Hmm – please remove your old website and then please try to restore a backup. Most probably you have find small bug which allows unpack backup in the same directory as your existing website before clearing it before.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #8691
    Avatar photoeranm

    Hi again Tomasz. Sorry, did you mean removing/deleting the entire site in publii and then use the backup to create a new site, or something else?

    Is there a specific way to delete an entire site in publii?

    #8692
    Avatar photoeranm

    Never mind. I got it to work this time. Thanks. Hopefully it will work again in future.

    #8827
    Avatar photoeranm

    Hi again Tomasz

    OK, I have encountered this error again with a different wp site export.

    Its just sitting there saying “Importing data…”, but nothing is happening.

    I tried attached the XML file, but it is 11750kb in size, so too big.

    So then I tried deleting the entire site from Publii first & resetting it up again, but that didn’t help.

    So instead, I just exported the primary pages (file size 2714kb) but that didn’t work either.

    BTW, it said

    “During WXR analysis, we have found:

    1 post

    266 pages

    1 image

    0 tags

    0 categories

    5 authors

    BTW, I tried attaching the new smaller XML file and it said

    “Error! File type not allowed.”

    Thanks in advance for your help.

     

     

    Attachments:
Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.