Sign in
We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Error Opening App – Publii Cannot Find Folder

  • This topic has 6 replies, 2 voices, and was last updated 2 months, 1 week ago by .
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #11298
    Avatar photojbruno

    I can’t seem to access anything anymore, I’m completely locked out! Every time I click to open the Publii app, it says the path doesn’t exist, but it does. I even tried deleting the Publii app and downloading again but it seems to remember the path and gives the same error.

    The exact error message is:

    “Publii cannot find your sites folder. Please check if the directory [inserts path] exists or create it manually, then reopen the application. ”

    I have checked and confirmed that the exact path listed in the error message does in fact exist. I can’t recreate it since it is already there. I’m not sure how to resolve this. I can’t even get to the app to choose the location again since this popup prevents Publii from opening at all.

    #11299
    Avatar photojbruno
    This reply has been marked as private.
    #11301
    Avatar photoBob

    Have a look at this topic: https://forum.getpublii.com/topic/missing-websites/

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #11302
    Avatar photojbruno
    This reply has been marked as private.
    #11305
    Avatar photojbruno
    This reply has been marked as private.
    #11306
    Avatar photojbruno

    Ok, so here’s what I’ve tried, I deleted the Publii app yet again, and everything Publii related in documents. Then I installed Publii again, and added one of the sites over that is in dropbox to the default location of publii in documents under ‘sites’.

    I was then able to open Publii and confirm that the default path was the same and saved, which gave me this lovely error message:

    Screenshot-2023-12-13-at-4.14.29-PM

    If I delete the Publii folder that’s in documents again, I can get back to the view to choose the path. I tested choosing the main location which is in dropbox and just get the same javascript error. So at least I’ve figured out how to change the path location, but the javascript error stops me from being able to access anything.

    I’ve scoured the topics and have yet to see a resolution to this issue. Any help would really be appreciated!

     

    #11310
    Avatar photojbruno

    Here’s a follow up to my last update. I created a copy of the sites, deleted everything everywere that was related to Publii and started from scratch. Set up a new folder structure in Dropbox, added the sites, downloaded Publii again, pointed to the new Dropbox sites location and finally have it working again!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.