Sign in

Publii integration with Cloudflare Pages

  • This topic has 9 replies, 3 voices, and was last updated 5 months ago by .
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #7684
    Avatar photoildrosos

    Hello I have followed your documentation in order to integrate Publii with my github account and then with Cloudflare Pages.

    Integration works fine except one thing :

    All internal links which guide the visitor to the other pages like Post titles , Logo URL , Menu items still point to my github account.

    So I can visit my homepage through cloudflare page url but then everywhere I click I am redirected to my github account url .

    How can I change this behavior ?

    #7692
    Avatar photoildrosos

    Noone knows how to change publii internal urls to point to cloudflare pages?

    #7698
    Avatar photoballoon

    Hi ildrosos,

    You would have deployed once with the GitHub Pages settings.
    Did you change the Website URL to https://example.pages.dev/ and redeploy?

    Also, Cloudflare Pages currently supports Direct Uploads. In this case Publii can select Manual deployment.
    You don’t have to go through GitHub or GitLab.
    https://developers.cloudflare.com/pages/platform/direct-upload/

    #7752
    Avatar photoildrosos

    Hello Balloon ,

    Thank you for your answer. I only deployed once and since then i just sync the site each time I make changes. I did not change the url since there is no way to do that if you dont change the domain to a custom domain.

    I will try the manual methos and post back thanks

    #7753
    Avatar photoildrosos

    Hello again , I tried to direct upload the website files from the website folder/output. Site is working byt internal links still point to github. So I suppose this is related to publii not cloudflare . Please advice

    #7757
    Avatar photoballoon

    I will check with you again.

    Did you change the Website URL to https://example.pages.dev/ and redeploy?
    For GitHub Pages, it’s https://example.github.io/. You need to change it.

    From your comment, it looks like you’re not doing that, so that doesn’t help. Take a closer look at Publii’s server deployment settings.

    #7758
    Avatar photoakickindienutz

    Hi,

    I am not sure if this is any use, but looks like someone else had a similar problem before from reading through the Foum: https://forum.getpublii.com/topic/deploying-to-github-then-cloudflare-pages/. The article suggests that it may be a case of changing the website URL in the Publii Server Settings.

    Other than that I was trying to check through my own website which uses GitHub Repo and Cloudflare Pages to see if there might be anything else. I am afraid I don’t remember seeing the problem you describe though. Not sure if you are using a Custom Domain or not or also maybe to do with DNS settings in Clouflare?

    Hoping someone on here can help you more.

    #7759
    Avatar photoballoon

    I operated Publii just in case and noticed something.

    Did you save by clicking Save Settings after changing the Website URL?

    Click Visit Website to see the current URL. Make sure it is the correct URL.
    Even if you change an item, it may not actually be reflected.

    #7760
    Avatar photoildrosos

    Hello all ,

    Thank you very much for your help Baloon is absolutely right I hadn’t changed the url in server settings inside Publii :

    I just chanfed it and it works fine .

    Thanks again

     

    #7761
    Avatar photoakickindienutz

    Pleased to hear you got it sorted 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.