We're evolving to serve you better! This current forum has transitioned to read-only mode. For new discussions, support, and engagement, we've moved to GitHub Discussions.

Still a problem: Netlify error: Max site size exceeded (104857600)

  • #2935
    Avatar photo[anonymous]


    other people had the problem before

    I had it on one of my sites, now on another site. The workaround mentioned in the post above doesn’t work any longer (Netlify disabled the possibility for manual uploads after the first deploy – or at least I can’t find the function).

    The guys at Netlify are still pointing the finger to Publii:

    Any ideas what might going on? Thanks

    Avatar photo[anonymous]

    I’ve given up on this one. I just upload the files manually to Netlify… Wish there were a solution.

    Avatar photo[anonymous]

    Thanks! It’s good to know that I’m not alone with my frustration!

    Avatar photo[anonymous]


    The “newline issue” is something new in this case, some time ago they were unable to provide a reason. I am unable to reproduce this issue, but I will try to add some additional validation on the filenames during netlify upload in upcoming 0.36.1 release.

    Avatar photo[anonymous]

    Thanks a lot!

    My half-automatic workaround now:

    In Publii under “Server Type”

    • “non-compressed catalog”
    • Output directory: “folder_1

    Files from folder_1 are copied to folder_2.  I use Hazel from Noodlesoft for auto-copying, but a script would work, too.

    folder_2 is a local GitHub-Repo. From there I commit and push to GitHub,  Netlify builds and deploys.

    Choosing “folder_2” directly as the output directory doesn’t work, because Publii overwrites the folder (and kills the hidden .git-folder).

    It’s not so simple and elegant as just pressing the button in Publii, but it works.

    And by the way: thanks for your great work!

    Avatar photo[anonymous]

    Can somebody share with me a backup of website which causes issue on Netlify?

    Because I have tried to broke Netlify sync, but I am unable 🙂 I have even tried images with spaces and slashes in their filenames – always it is working fine.

    Also in the code I do not see any reason and place where newline characters could appear :/

    Avatar photo[anonymous]

    Try the website I just shared in my other ticket. It always errors out on Netlify.

    Avatar photo[anonymous]
    This reply has been marked as private.
    Avatar photo[anonymous]

    @elmo – thanks for sharing your backup – I was able to reproduce your issue on my machine 🙂

    I have found one thing – missing content-type header (I have found it mentioned in Netlify documentation). After that sync started to working again 🙂

    I will make this fix available in the upcoming v.0.36.1 on the next week 🙂

    I do hope that it was a reason, and as you can see – the error message is strange and totally not connected with the real reason of the issue.

    Avatar photo[anonymous]

    Thanks! I really appreciate it! (so i just donated a bit…)

    Avatar photo[anonymous]

    Publii 0.36.1 fixed it. Thanks!!